Versionen im Vergleich

Schlüssel

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Ausgangssituation

  • Es werden  mehrere Datenbestände von ADVOKAT verwendet.
  • Es erscheint beim Start eines oder gar mehrere Datenbestände eine Fehlermeldung.

Fehlermeldung

  • Fehler bei der Anmeldung für den Benutzer "Advokat".bei der Durchführung der Migration Fehlermeldungen im Protokoll zu allen zu migrierenden Dateien aufgezeichnet.

Fehlermeldung

  • Advokat8.DMS.Sharepoint.Manager.Remove.Remover) File /AdvokatSharePointWinword/...Pfad.../Dateiname.Dateiendung skipped.
  • Advokat8.DMS.Sharepoint.Manager.Remove.Remover) Error copying /AdvokatSharePointWinword/...Pfad.../Dateiname.Dateiendung to S:\ADVOKAT\Daten\Winword\...Pfad...\Dateiname.Dateiendung
    Microsoft.SharePoint.SPException: Kann Datei "/AdvokatSharePointWinword/...Pfad.../Dateiname.Dateiendung" nicht öffnen. ---> System.Runtime.InteropServices.COMException: <nativeehr>0x81070211</nativehr>

Ursache

In einem oder mehreren Datenbeständen fehlt in der Konfigurationsdatei "Advokat.ini" der Konfigurationschalter "SWID=..." oder dieser ist falsch.

Lösung

...

  1. Schließen Sie das ADVOKAT Migrationstool und stellen Sie sicher, dass mindestens ADVOKAT Version 6.22d oder höher verwendet wird.  
    Im Bedarfsfall führen Sie ein ADVOKAT Update durch, siehe Kapitel ADVOKAT Update. Welche Version im Einsatz ist kann per Menüpunkt "?" > "Info" in der Zeile "Programmversion" ermittelt werden.

  2. Verbinden Sie sich per Remotedesktop auf den Microsoft SharePoint-Server, als Windows Benutzerkonto muss der SharePoint Administrator gewählt werden.
    Navigieren Sie per Windows Explorer das ADVOKAT Backend unter "...\ADVOKAT\
    Daten".
    Öffnen Sie die Konfigurationsdatei "Advokat.iniAdmin\Support\Adv2SharePoint" und öffnen die Datei "???" mit einem Texteditor und suchen Sie nach dem Konfigurationsschalter "SWID=...".
    Info
    titleBeispiel

    SWID=6#32##15##25#=#1##15#

    Wechseln Sie zum ADVOKAT Backend des nächsten Datenbestandes und öffnen Sie die Konfigurationsdatei "Advokat.ini".
    Stellen Sie in dieser Datei sicher, dass der Konfigurationsschalter "SWID=..." ebenfalls existiert.
    Mit hoher Wahrscheinlichkeit fehlt unter Schritt 2 der Konfigurationsschalter.
    Fügen Sie in der Datei den Konfigurationsschalter laut Schritt 1 an der gleichen Stelle ein.

  3. Falls es weitere Datenbestände gibt wiederholen Sie schritt 2 und 3 für jeden Datenbestand. Abschließend versuchen Sie erneut ADVOKAT zu starten.
    Tritt das Problem weiterhin auf, so kontaktieren Sie den ADVOKAT Support per Mail (support@advokat.at) oder telefonisch unter +43 512 / 58 80 33xyz

  4. Starten Sie nun das SharePoint-Tool "Advokat8.DMS.SharePoint.Manager.exe" im Verzeichnis laut Schritt 2 und versuchen erneut die Migration durch wie im Kapitel Durchführung beschrieben.