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  • Fehler beim Prüfen des Root-Zertifikates: Der Zugriff auf den Pfad "C:\Program Files (x86)\Advokat\CA.pfx" wurde verweigert.

  • Fehler beim Prüfen des Root-Zertifikates: Der Zugriff wurde verweigert.

  • Fehler in der Webserviceroutine => App failing...System.ServiceModel.AddressAccessDeniedException: HTTP konnte URL "https://+:8000/AdvService/" nicht registrieren.
    Der Prozess weist keine Zugriffsrechte für diesen Namespace auf.

Ursache

  1. Dem Serviceaccount für AdvoAll AdvoAll-Benutzerkonto (üblicherweise “Domäne\svc_advokat”) fehlen lokale administrative Rechte.

  2. Die Benutzerkontensteuerung (UAC) des Betriebssystems blockiert trotz lokaler administrativer Rechte den Zugriff.

Lösung

  1. Stellen Sie sicher, dass der Serviceaccount, welcher für AdvoAll genutzt wird, das AdvoAll-Benutzerkonto am AdvoAll-Gerät ober über lokale administrative Rechte verfügt.
    Stellen Sie sicher, dass Sie am AdvoAll-Gerät nicht als Domänenadministrator sondern mit dem AdvoAll-Benutzerkonto im Zuge der Installation angemeldet sind.

  2. Navigieren Sie auf zum ADVOKAT Client (Frontend) unter "C:\Program Files (x86\Advokat)" und starten Sie "AdvoAll.exe". Markieren Sie den Eintrag "AdvokatADVOKAT_Mobile" > "Bearbeiten" > "Konfiguration bearbeiten".

    • Klicken Sie im Fenster "ADVOKAT RestService Setup" auf OK, um sicherzustellen, dass nicht die Meldung "Fehler beim Prüfen des Root-Zertifikats: Zugriff verweigert" erscheint. 

    • Tritt das Problem weiterhin auf, fahren Sie mit Schritt 3 fort.

  3. Starten Sie das Befehlszeilenkommando (CMD) per Rechtsklick > "Als Administrator ausführen".

    • Fügen Sie das Netzlaufwerk von ADVOKAT im Kontext des Standard-Administrator hinzu, damit dieses trotz aktiver Benutzerbenutzerkontensteuerung (UAC) gefunden wird.

    • Wiederholen Sie Schritt 2, tritt das Problem weiterhin auf, fahren Sie mit Schritt 4 fort.

  4. Öffnen Sie den Registrierungseditor (regedit) am AdvoAll-Gerät und navigieren Sie zu beiden Pfaden:

    • [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\SystemCertificates]

    • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SystemCertificates\Root].

    • Per Rechtsklick > "Berechtigungen" geben Sie dem Serviceaccount von AdvoAll-Benutzerkonto jeweils in beiden Verzeichnissen "Vollzugriff".

    • Wiederholen Sie Schritt 2, tritt das Problem weiterhin auf, fahren Sie mit Schritt 4 5 fort.
       

  5. Öffnen Sie den Registrierungseditor (regedit) und navigieren Sie zu: [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Policies\System\]
    Setzen Sie beim Eintrag "EnableLUA" vom Typ "REG_DWORD" den Wert auf "0". Starten Sie das Gerät neu und wiederholen Sie Schritt 2.