Ausgangssituation
- Der Telefonassistent wurde erfolgreich eingerichtet und konnte bereits erfolgreich verwendet werden.
- Bei Programmstart von ADVOKAT erscheint keine Fehlermeldung, dennoch kann das Modul nicht verwendet werden.
Ursache
- Der TAPI-Treiber ist abgestürzt oder reagiert nicht.
- Die Attribute in der Datei "Kanzlei.cfg" beim Element Telefonie sind falsch.
Lösung
- Starten Sie den Arbeitsplatz neu - dadurch wird der TAPI-Treiber neugestartet - und prüfen Sie ob die Fehlermeldung beim Programmstart weiterhin erscheint.
Dieser Schritt ist meist nur eine temporäre Lösung des Problems. Bei wiederholtem Auftreten ist es ratsam eine höhere Version des TAPI-Treibers zu installieren. - Navigieren Sie zur Datei "Kanzlei.cfg im ADVOKAT Backend unter "...\ADVOKAT\Daten\Config". Es handelt sich dabei um eine Textdatei, öffnen Sie diese mit einem beliebigen Texteditor.
Navigieren Sie zum Element Telefonie und testen Sie ob der Telefonassistent funktioniert, wenn die Attribute AmtPrefix, Ortsvorwahl und A8Tapi korrigiert werden.
Die Beschreibung der einzelnen Attribute findet man im Kapitel Beschreibung der Attribute.
Beispiel (vorher)
<Telefonie AmtPrefix="0" OrtsVorwahl="01" IntVorwahl="+43" KeineDeviceAnfrage="0" InitialUnterdrückteRufnummern="Anonym" Fehlend="VR" Flags="V;R" A8Tapi="0">
<TelComputer Name="JD-PC" Device="Control ECSTA for Hipath 2000"/>
</Telefonie>
Beispiel (nachher)
<Telefonie AmtPrefix="00" OrtsVorwahl="0512" IntVorwahl="+43" KeineDeviceAnfrage="0" InitialUnterdrückteRufnummern="Anonym" Fehlend="VR" Flags="V;R" A8Tapi="3">
<TelComputer Name="JD-PC" Device="Control ECSTA for Hipath 2000"/>
</Telefonie> - Starten Sie ADVOKAT neu und testen Sie den Telefonassistent auf seine Funktionalität.