Ausgangssituation
- Es ist die Synchronisation mit Microsoft Exchange im Einsatz, siehe Kapitel Synchronisation mit Microsoft Exchange.
Ursache
Es gibt mehrere mögliche Ursachen, es können auch mehrere gleichzeitig zutreffen:
- Die Schritte 2 bis 9 wie im Kapitel Synchronisation mit Microsoft Exchange beschrieben wurden nach einer Migration von Microsoft Exchange nicht durchgeführt.
- Es kam mitten in der Synchronisation zu einem Verbindungsabbruch von AdvoAll zum Datenbankserver und/oder Microsoft Exchange.
Lösung
Navigieren Sie in ADVOKAT zum Menüpunkt "Programme" > "Terminkalender". Im Terminkalender wechseln Sie zur Ansicht "Evidenzliste" und klicken auf "Filter/Ansicht" > "Filter einstellen".
Datum von: Heute minus 60 Tage
Datum bis: leer
Benutzer: leer
Suchziel: 2 | ‚Für SB' und ‚Von' durchsuchen
Terminart: Alle Terminarten, welche auch in A4OlSync eingestellt sind.
"Auch erledigte Termine anzeigen" aktivieren.Markieren Sie alle Terminduplikate, in diesem Beispiel die unteren 5 Stück, per Menüpunkt "Bearbeiten" > "Löschen" oder Entfernen-Taste sind diese zu löschen.
Ist die Löschung aller Terminduplikate auf diesem Weg zu zeitaufwendig, beispielsweise weil es hunderte oder tausende Terminduplikate gibt – so wechseln Sie zu Schritt 2.- Verbinden Sie sich per Remotedesktopverbindung auf den Datenbankserver und starten Sie Microsoft SQL Management Studio.
Verbinden Sie sich mit jener Microsoft SQL Instanz, welche die ADVOKAT Datenbanken beinhaltet. Abfrage von Terminduplikaten: Mit dieser Abfrage können Sie prüfen, wie viele Terminduplikate existieren.
USE [Advokat_DATEN] GO SELECT * FROM dbo.Termin where concat(ANr, Datum, Zeit, Dauer, Ende, Sender, SB, Person, Betreff, Memo, Art, Erledigt, Geschützt, Flag, Tag, Pfad) IN (SELECT Wert FROM (SELECT Zähler, concat(ANr, Datum, Zeit, Dauer, Ende, Sender, SB, Person, Betreff, Memo, Art, Erledigt, Geschützt, Flag, Tag, Pfad) AS Wert FROM dbo.Termin) AS tmp group by wert having count(Zähler) > 1) order by Anr, Datum, Zeit GO
Löschung von Terminduplikaten: Mit dieser Abfrage können Sie alle gefundenen Duplikate löschen.
Stellen Sie sicher, dass die Tabelle dbo.TerminDuplikate nicht existiert, ist diese Tabelle vorhanden, muss sie vorher gelöscht werden.USE [Advokat_DATEN] GO SELECT * INTO dbo.TerminDuplikate FROM dbo.Termin WHERE concat(ANr, Datum, Zeit, Dauer, Ende, Sender, SB, Person, Betreff, Memo, Art, Erledigt, Geschützt, Flag, Tag, Pfad) in (SELECT Wert FROM (SELECT Zähler, concat(ANr, Datum, Zeit, Dauer, Ende, Sender, SB, Person, Betreff, Memo, Art, Erledigt, Geschützt, Flag, Tag, Pfad) AS Wert FROM dbo.Termin) AS tmp GROUP BY wert HAVING COUNT(Zähler) > 1) ORDER BY anr, datum, zeit GO DELETE FROM dbo.TerminDuplikate WHERE Zähler IN (SELECT Kleinster from (select MIN(Zähler) AS Kleinster, Wert FROM (SELECT Zähler, concat(ANr, Datum, Zeit, Dauer, Ende, Sender, SB, Person, Betreff, Memo, Art, Erledigt, Geschützt, Flag, Tag, Pfad) AS Wert FROM dbo.Termin) AS tmp GROUP BY Wert HAVING COUNT(Zähler) > 1) AS tmp2) GO DELETE FROM dbo.Termin WHERE Zähler IN (SELECT Zähler FROM dbo.TerminDuplikate) GO
Nach Ausführung der Befehle löschen Sie die entstandene Tabelle dbo.Terminduplikate!
- Aufgrund der Löschung in ADVOKAT wird die Löschung automatisch an Microsoft Exchange übertragen, die Terminduplikate müssen in Microsoft Office Outlook also nicht gelöscht werden.