1.5.3.3 Versionsabweichung des Server nach Update

Ausgangssituation

  • ADVOKAT Update wurde erfolgreich durchgeführt und trotzdem erscheint auf bestimmten Geräten beim Programmstart untenstehende Fehlermeldung.
  • Die Module "Compliance und "Executive Board" können nicht verwendet werden.

Fehlermeldung

  • Versionsabweichung. ADVOKAT Client und ADVOKAT Server weichen voneinander ab!
    Client Version: <Nummer>
    Server Version: <Nummer>

    Server Mindestversion: <Nummer>

Ursache
In diesem Fall ist die Server Version niedriger als die Client Version, diese müssen identisch sein. Beispielsweise: Server Version: 6.24.0.2, Client Version: 6.25.0.2
Ursache ist eine fehlgeschlagene Aktualisierung der Komponenten am ADVOKAT Server, also unter "...\ADVOKAT\Advokat.Server" im Zuge des Updates.

Verhält es sich umgekehrt, also die Client Version ist niedriger als die Server Version, dann wechseln Sie zum Kapitel Versionsabweichung des Servers nach Update.

Lösung

  1. Wird der ADVOKAT Server per ADVOKAT AdvoAll betrieben, dann fahren Sie mit Schritt A fort, wird der ADVOKAT Server per Microsoft IIS betrieben, dann mit Schritt B.
    1. Verbinden Sie sich per Remotedesktop auf jenes Gerät, auf dem ADVOKAT AdvoAll verwendet wird.
    2. Verbinden Sie sich per Remotedesktop auf jenes Gerät, auf dem ADVOKAT Server bzw. IIS-Manager (Internetinformationsdienste) installiert wurde.
       
  2. Sicherstellen, dass ADVOKAT und Microsoft Office Outlook auf allen Arbeitsplätzen geschlossen sind.
    • ADVOKAT Frontend auf einer Arbeitsstation oder Terminalserver starten.
    • Am Startbildschirm von ADVOKAT "STRG + SHIFT + Doppelklick linke Maustaste" drücken.
    • Option "Advokat Programmstart sperren" aktivieren.
    • Im Fenster "Optional zusätzlicher Text für die Meldung" einen Informationstext eingeben, Beispiel: ADVOKAT Migration von 08:00 bis 10:00 Uhr.

      Auf allen anderen Geräten kann ADVOKAT nun nicht mehr gestartet werden.
      Alle Benutzer, welche sich zu diesem Zeitpunkt noch im Programm befinden werden nach einer Wartefrist von 5 Minuten getrennt.
       
  3. Halten Sie die Taste "F12" gedrückt und starten Sie auf diesem Gerät "...\ADVOKAT\Advokat.exe". Es erscheint das Fenster "Aktualisierung von ADVOKAT Edition 6".
    Aktivieren Sie die Checkboxen "Netzinstallation erneuern",
    "Lokale Installation erneuern" als auch "Dateiinstallation erzwingen" und wählen "Fortsetzen". Mehr Informationen dazu finden Sie im Kapitel ADVOKAT Installationsmenü.

  4. Nun startet die automatische Reparatur von ADVOKAT. Warten Sie bis der Fortschritt 100% erreicht hat.
    Treten Fehlermeldungen auf, so können Sie versuchen, diese mit Klick auf "Wiederholen" zu übergehen. ADVOKAT wird versuchen die fehlgeschlagene Aktion erneut durchzuführen.

  5. Falls die erneute Reparatur erfolgreich war, so erscheint der Startbildschirm von ADVOKAT.
  6. Sperre des Programmstarts aufheben. Starten Sie ADVOKAT am gleichen Gerät wie bei Schritt 2, es erscheint folgende Meldung, welche Sie mit "Ja" bestätigen:

    Soll die Sperre für die anderen Benutzer wieder aufgehoben werden?

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