12.6.5 Securityrecht gleichzeitig zugelassen und verweigert

Ausgangssituation

  • Ein Securityrecht wird im Fenster "Effektive Rechte für <SB>..." als gleichzeitig zugelassen und verweigert angezeigt. In solch einem Konflikt gewinnt immer die Einstellung "Verweigern".

  • Das Fenster "Effektive Rechte für <SB>..." wird per Menüpunkt "Programme" > "Tabellen warten" > "Benutzer/Gruppen" > beim relevanten Benutzer per Schaltfläche "Befehle" > "Effektive Rechte" aufgerufen.

Beispiel

  • Benutzer "BB" darf in allen Akten der Aktengruppe "Standard-Akten-Gruppe" Akten nicht löschen.

  • Benutzer "MM" ist Mitglied der Benutzergruppen "Rechtsanwälte" und "Sekretariat".

  • Benutzergruppe "Rechtsanwälte" hat das Securityrecht "Akt löschen" auf "Zulassen" eingestellt.

  • Benutzergruppe "Sekretariat" hat das Securityrecht "Akt löschen" auf "Verweigern" eingestellt.

Ursache

Der betroffene Benutzer (SB) ist Mitglied von mindestens zwei Benutzergruppen.
Eine der relevanten Benutzergruppen hat dieses Securityrecht mit "Zugelassen", während andere relevante Benutzergruppen das Securityrecht mit "Verweigern" eingestellt haben.
Aufgrund der Zugehörigkeit des Benutzers zu beiden Gruppen werden beide Einstellungen angewendet.

Lösung

  1. Kontaktieren Sie einen Securityadministrator in Ihrem Unternehmen. Eine Liste der Securityadministratoren finden Sie in ADVOKAT per Menüpunkt "?" > "Info".

    • Im Infofenster im ersten Absatz werden die Administratoren in der Zeile (Administratoren: ....) aufgelistet.

    • Beachten Sie, dass der ADVOKAT Support nicht befugt ist die Einstellungen des Securitymodul auszuhebeln oder das Modul zu deaktivieren.

  2. Der Securityadministrator navigiert in ADVOKAT zum Menüpunkt "Programme" > "Tabellen warten" > "Benutzer und Gruppen".
    Der betroffene Sachbearbeiter wird in der Benutzerliste geöffnet. Im Feld "Mitglied von Gruppe" ermitteln Sie zu welchen Benutzergruppen der Benutzer gehört.

  3. Wechseln Sie zum Menüpunkt "Programme" > "Tabellen warten" > "Security". Navigieren Sie zu dem relevanten Securityrecht.

    • Wählen Sie in der Spalte "Bereich" jene Benutzergruppe, welche das Securityrecht mit "Verweigern" eingestellt hat.

    • Entfernen Sie den Eintrag "Verweigern". Ist ein Securityrecht weder mit "Zulassen" noch mit "Verweigern" eingestellt, so verhält sich ADVOKAT als ob "Verweigern" gesetzt wäre.

    • Als Resultat dieser Anpassung gibt es beim Benutzer (SB) keinen Konflikt mehr zwischen "Zulassen" und "Verweigern", daher greift die Einstellung "Zulassen".

Copyright © 2024 ADVOKAT Unternehmensberatung GREITER & GREITER GmbH - Impressum ->https://advokat.at/Impressum.aspx