12.6.6 Fehler bei Benutzer-/Gruppen- oder Securityänderungen

Ausgangssituation

  • ADVOKAT ist an Microsoft SharePoint On-Premise angebunden, siehe Kapitel ADVOKAT mit Microsoft SharePoint On-Premise.

  • Ein(e) neue(r) Benutzer/Gruppe wird unter "Programme" > "Tabellen warten" > "Benutzer/Gruppen" angelegt, es tritt eine Fehlermeldung auf oder der Vorgang dauert viel zu lange.

  • Ein(e) bestehende(r) Benutzer/Gruppe wird unter "Programme" > "Tabellen warten" > "Benutzer/Gruppen" verändert, es tritt eine Fehlermeldung auf oder der Vorgang dauert viel zu lange.

  • Eine beliebige Änderung in der Security unter "Programme" > "Tabellen warten" > "Security" wird vorgenommen, es tritt eine Fehlermeldung auf oder der Vorgang dauert viel zu lange.

Beispiele (Fehlermeldung)

  • Fehler: FSecGruppenzugehoerigkeit.Run
    Advokat8.DMS; SetDmsRightsForUsers: Fehler beim Setzen der Security in der DMS.
    DmsSetRights: Fehler beim Setzen der Security in der DMS. x Error(s) in ACLSetEntries

  • Fehler: FSecSichEinstBereich.Run Advokat8.DMS; DmsSetRights: Fehler beim Setzen der Security in der DMS.
    x Error(s) in ACLSetEntries
    The following users were ignored: ADVOKAT\JD - http://sharepointserver/AdvokatSharePointWinword–2146233088

Ursache

Es gibt in ADVOKAT mindestens 1 Benutzer, welcher mit einem deaktivierten/gesperrten/gelöschten Windows Domänenkonto verknüpft ist.
In Folge können die Benutzer-/Gruppen- oder Securityeinstellungen in Microsoft SharePoint On-Premise durch ADVOKAT nicht durchgeführt werden oder benötigen mehr Zeit als üblich.

Wir empfehlen Änderungen (Deaktivierung/Sperrung/Löschung/Umbenennung) von Windows Domänenkonten in Active Directory sofort in ADVOKAT nachzuziehen.
Häufige Fälle sind die automatische Sperrung eines Kontos oder die Deaktivierung weil der Mitarbeiter nicht mehr im Unternehmen tätig ist.

Lösung

  1. Falls Sie von einem der Kapitel Module/Funktionen bei bestehendem Benutzer nicht aufrufbar oder Module/Funktionen bei neuem Benutzer nicht aufrufbar weitergeleitet wurden:
    Schließen Sie die aufgetretene Fehlermeldung mit Schaltfläche "Abbrechen". Andernfalls wechseln Sie zu Schritt 2.

  2. Kontaktieren Sie einen Securityadministrator in Ihrem Unternehmen. Eine Liste der Securityadministratoren finden Sie in ADVOKAT per Menüpunkt "?" > "Info".

    • Im Infofenster im ersten Absatz werden die Administratoren in der Zeile (Administratoren: ....) aufgelistet.

    • Beachten Sie, dass der ADVOKAT Support nicht befugt ist die Einstellungen des Securitymodul auszuhebeln oder das Modul zu deaktivieren.

  3. Der Securityadministrator navigiert in ADVOKAT zum Menüpunkt "Programme" > "Tabellen warten" > "Benutzer und Gruppen".
    Im Reiter "Benutzer" ist der betroffene Benutzer zum Domänenkonto zu suchen. Dieser ist in der Fehlermeldung ersichtlich.

    • Öffnen Sie den Benutzer und löschen Sie den Eintrag im Feld "Windows Benutzername".

    • Die Checkbox “Dieser Benutzer hat eine ADVOKAT Lizenz” ist zu deaktivieren und Checkbox “Dieser Benutzer ist inaktiv” zu aktivieren.

    • Tritt beim Klick auf "OK" oder "Befehle" > "Speichern" eine Fehlermeldung auf, so wählen Sie "Ignorieren". In diesem Fall gibt es weitere betroffene Benutzer.

       

  4. Wiederholen Sie Schritt 3 für jedes weiteren Benutzer (Windows Benutzerkonto), welcher inaktiv ist im Protokoll oder der Fehlermeldung erscheint.
    Abschließend versuchen Sie erneut die eigentliche Anpassung vorzunehmen, welche laut Ausgangssituation bzw. laut Punkt 1 abgebrochen wurde.

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