4.1.10.8.5 Meldung "Kontakt mit dem Server ..."

Ausgangssituation

  • Das Erstellen und Öffnen von Word-Dokumenten dauert bis zu 2 Minuten, es erscheint in Word folgende Meldung: Kontakt mit dem Server zum Abrufen von Informationen wird hergestellt ...

    • In der Meldung steht weiters, dass versucht wird eine Datei auf einem Server zuzugreifen, welcher nicht mehr in Verwendung ist.

  • Dieses Problem tritt erst auf, nachdem Microsoft SharePoint auf einen anderen Server migriert wurde, also eine Servermigration stattfand.

Beispiele (Meldung)

  • Kontakt mit dem Server zum Abrufen von Informationen wird hergestellt. Datei: "http://SharePoint-Server-alt/AdvSP/Arbeitsbehelfe/Word/Formatvorlagen.dotx"

Ursache

Allgemeine Informationen finden Sie in diesem Microsoft Artikel. In den Word-Dokumenten wird auf eine Datei verwiesen, welche auf einem Server gespeichert ist, welcher nicht mehr in Verwendung ist.
In der Regel handelt es sich dabei um Word-Vorlagen, also Dateien mit Endung .DOT, .DOTM und .DOTX und diese befinden sich in einer SharePoint Dokumentbibliothek, welche auch migriert wurde.

Während die Word-Vorlagen (DOT/DOTM/DOTX) selbst aufgrund der Migration nun einer SharePoint Dokumentbibliothek auf einem Server liegen, steht in den Word-Dokumenten weiterhin der Pfad vom alten Server.
Word versucht 2 Minuten lang auf diese Datei zuzugreifen und erst danach wird das eigentliche Word-Dokument geöffnet, da die Datei am alten Server nicht gefunden werden konnte.

Lösung

  1. Als kurzfristige (sofortige) Hilfsmaßnahme kann jeder Anwender jedes Mal die Taste "ESC" drücken, wenn ein Dokument erstellt oder geöffnet wird.
    Dadurch versucht Word nicht vergeblich 2 Minuten lang beim Versuch die Word-Vorlage zu öffnen sondern das eigentlich Word-Dokument kann sofort bearbeitet werden.

  2. Stellen Sie sicher, dass neu erstellte Word-Dokumente auf die Word-Vorlage (DOT/DOTM/DOTX) am neuen Server, also der neuen SharePoint Dokumentbibliothek zugreifen.
    In der Regel muss dazu die Word Datei "Normal.dotm" aktualisiert werden. In manchen Fällen ist zusätzlich die Anpassung Anwendungsvorlagen in den Optionen von Word je Arbeitsplatz erforderlich.

  3. Es besteht keine einfache Möglichkeit, in allen existierenden Dokumenten den Pfad der Word-Vorlagen anzupassen. Wir empfehlen eine Gruppenrichtlinie oder ein Skript, um die Betriebssystemdatei "hosts" anzupassen.
    Es wird dann die Datei vom neuen Server angefordert und die Meldung "Kontakt mit dem Server ..." erscheint nicht mehr.

  4. Bearbeiten Sie auf allen betroffenen Geräten die Datei "hosts" im Verzeichnis "C:\Windows\System32\drivers\etc\" mit einem Texteditor.

    • In der Datei ist am Ende ein entsprechender Eintrag in einer neuen Zeile zu setzen. Es ist zu testen, welche Variante funktioniert:

      <Servername (alter SharePoint-Server)> <Servername (neuer SharePoint-Server)> SHAREPOINT-SERVER-ALT SHAREPOINT-SERVER-NEU
    • Sollten Sie die Meldung erhalten, dass die Datei schreibgeschützt ist, dann kopieren Sie diese beispielsweise auf den Desktop.
      Am Desktop wird die Datei bearbeitet und abschließend retour nach "C:\Windows\System32\drivers\etc\" gespeichert (überschrieben).

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