4.1.10.8.1 Dokument nicht erstell-/öffenbar

Ausgangssituation

  • In einem bestimmten Akt können existierende Dokumente nicht geöffnet werden und neue Dokument nicht erstellt werden.

  • Beim Drücken von "F9" im Modul "Aktenverwaltung" öffnet sich der Windows Explorer mit dem Ordner zum Akt, es werden jedoch keine Dateien oder Unterordner angezeigt.

Beispiele (Fehlermeldungen)

  • Fehler: Text1.Run
    A8Client; Der Remoteserver hat einen Fehler zurückgegeben: (401) Nicht autorisiert.-5

  • Fehler: UCAktVerwaltungAkt.PasteDrop
    A8Client; Der Remoteserver hat einen Fehler zurückgegeben: (401) Nicht autorisiert.-5

Ursache
Der betroffene Akt hat die Vererbung der Berechtigungen in Microsoft SharePoint verloren. In diesem Beispiel lautet der Akt: ADVOKAT/TEST
Dies geschieht beispielsweise, wenn die Berechtigungen für einen Akt nicht in ADVOKAT, sondern in Microsoft SharePoint konfiguriert werden, dies wird nicht unterstützt.

Lösung

  1. Starten Sie ADVOKAT auf dem Arbeitsplatz eines Securityadministrators und drücken Sie am Startbildschirm "STRG + SHIFT + Doppelklick linke Maustaste".

    • Wählen Sie im Menü die Option "Akten-Security berichtigen", es öffnet sich der Suchassistent, wählen Sie den betroffenen Akt aus. Klicken Sie zuletzt auf "OK".

    • ADVOKAT versucht die Berechtigungen in Microsoft SharePoint vollautomatisch zu korrigieren, hilft dies nicht ist mit Punkt 2 fortzufahren.

  2. Stellen Sie auf den betroffenen Geräten sicher, dass vom Windows Dienst “WebClient” die automatische Anmeldung an Microsoft SharePoint funktioniert.
    Alle notwendigen Informationen dazu finden Sie im Kapitel WebDAV (WebClient) verlangt Anmeldeinformationen.

  3. Verbinden Sie sich per Remotedesktop auf den Microsoft SharePoint-Server, als Windows Benutzerkonto muss der SharePoint-Administrator gewählt werden.

    • Öffnen Sie den Internet Browser und navigieren Sie zur Microsoft SharePoint Website. Wechseln Sie dort zur Dokumentbibliothek "AdvokatSharePointWinword" bzw. "AdvSP" und dann zum betroffenen Akt.

    • Ist die URL der Microsoft SharePoint Website unbekannt, so finden Sie diese beim Bereich "Microsoft SharePoint Dokumentenmanagement" im Feld "Bibliothek" in ADVOKAT.

      • Navigieren Sie in ADVOKAT zum Menüpunkt "System" > "Einstellungen" > Reiter "Dokumente" > Schaltfläche "Weitere Einstellungen" > Reiter "Verzeichnisse" > Schaltfläche "Einstellungen für Dokumentablage bearbeiten".


  4. Navigieren Sie zum Aktenordner unter A > ADVOKAT > TEST. Beim Ordner "TEST" klickt man auf "...", dann klicken Sie auf "Freigegeben für viele Personen".

    • Je nach Systemeinstellung von ADVOKAT ist die Ordnerstruktur von Akten unterschiedlich. Der Pfad muss nicht zwingend A > ADVOKAT > Test lauten, sondern kann auch A > ADVOKAT_TEST sein.

      • Bei Fragen oder Unklarheiten dazu ziehen Sie bitte den ADVOKAT Support hinzu.

    • Es erscheint das Fenster "Geteilt mit" und man klickt auf "Erweitert". Nun befindet man sich in der Berechtigungsverwaltung für den Akt "ADVOKAT/TEST". 

       

  5. Es ist ein gelb markierter Hinweis ersichtlich: "This folder has unique permissions" (Dieser Ordner hat eigene Berechtigungen).

    • Diese Meldung besagt, dass die Berechtigungen falsch sind und korrigiert werden müssen. Wählen Sie die Option "Eindeutige Berechtigungen löschen" und bestätigen Sie Sicherheitsabfrage.

    • Dadurch hat der Akt wieder die Berechtigungen wie in ADVOKAT per Securitymodul definiert.

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