4.1.10.8.3 Dokumente werden nicht in SharePoint gespeichert

Ausgangssituation

  • Ein Dokument wird beispielsweise per Copy & Paste oder Drag & Drop in einem ADVOKAT Akt abgelegt.

  • Es erscheint keine Fehlermeldung, das Dokument kann auch geöffnet werden, es wurde jedoch nicht in der SharePoint Dokumentbibliothek sondern am Fileserver abgelegt.

Fehlermeldungen (Beispiele)

  • Aufgrund eines unerwarteten Fehlers können Sie die Datei nicht kopieren. Wenn der Fehler weiterhin ausgegeben wird, können Sie mithilfe des Fehlercodes in der Hilfe nach diesem Problem suchen.
    Fehler 0x0800700DF: Die Dateigröße überschreitet die maximal zulässige Größe und kann nicht gespeichert werden.

Ursache
Es gibt drei mögliche Ursachen, diese können auch gleichzeitig zutreffen:

  1. Dateien mit mehr als 250 MB sind in Microsoft SharePoint seitens Microsoft standardmäßig verboten.

  2. Dateien mit mehr als 50 MB sind in Microsoft SharePoint durch den Windows Dienst "WebClient" standardmäßig verboten.

  3. Bestimmte Dateitypen/-endungen sind in Microsoft SharePoint seitens Microsoft standardmäßig verboten. Eine Übersicht finden Sie im Kapitel Verbotene Dateiendungen, Sonderzeichen und Ordnernamen, Punkt 1.

Lösung

  1. Verbinden Sie sich per Remotedesktop auf den Microsoft SharePoint-Server, als Windows Benutzerkonto muss der SharePoint-Administrator gewählt werden.

  2. Navigieren Sie per Windows Explorer im ADVOKAT Backend zur Konfigurationsdatei "...\ADVOKAT\Daten\Advokat.ini" und öffnen diese mit einem Texteditor.
    Mehr Informationen dazu finden Sie im Kapitel Datei "Advokat.ini". Suchen Sie nach dem Konfigurationsschalter SPSetDav und setzen diesen von 0 auf 1.

    • Vorher: SPSetDav=0

    • Nachher: SPSetDav=1
       

  3. Öffnen Sie per Windows Explorer das ADVOKAT Backend unter "...\ADVOKAT\Admin\Support\Adv2SharePoint" und starten das Tool "Advokat8.DMS.SharePoint.Manager.exe".

    • Geben Sie im Feld "Advokat.ini" per Schaltfläche "Öffnen" den Pfad zur Konfigurationsdatei "Advokat.ini" an. Achten Sie darauf, den Pfad zur Datei wie aus Sicht eines Arbeitsplatzes anzugeben.

    • Markieren Sie die SharePoint Dokumentbibliothek und wählen Option "Erlaubte Dateiendungen bearbeiten".

      Screenshot_Schritt3.PNG

       

  4. Definieren Sie im Fenster "Blockierte Dateiendungen bearbeiten" was erlaubt bzw. verboten ist. Bestätigen Sie abschließend mit Klick auf "Übernehmen".

    • Hinweis: Dateien "lastfile.dat", "thumbs.db und "desktop.ini" werden auch dann nicht in SharePoint abgelegt, wenn die zugehörigen Dateiendungen erlaubt sind.

    • Wiederholen Sie diesen Schritt falls mehrere Dokumentbibliotheken verwendet werden für jede Dokumentbibliothek.

      Screenshot_Schritt4.png

       

  5. Im Bereich "Globale Optionen festlegen" wird die maximale Dateigröße im Feld "Maximale Dateigröße in MB" definiert. Standardmäßig sind 250 MB hinterlegt.

    • Geben Sie den gewünschten höheren Wert an, ein Klick auf Schaltfläche "Anwenden" ist nicht erforderlich.

    • Markieren Sie die vorhandene(n) Dokumentbibliothek(en) und wählen jeweils rechts die Option "Einstellungen korrigieren". Bei Fehlermeldungen wechseln Sie zum Kapitel SharePoint-Tool Fehlermeldungen.

    • Dadurch wird in der markierten Dokumentbibliothek die erlaubte Dateigröße angepasst. Die Abfrage "Maximale Dateigröße auch in den ADVOKAT Einstellungen aktualisieren?" bestätigen Sie mit "Ja".

       

  6. ADVOKAT muss auf allen Arbeitsplätzen geschlossen und erneut gestartet werden.

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