Versionen im Vergleich

Schlüssel

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...

  • Bei Programmstart von ADVOKAT und/oder bei der Verwendung des Telefonassistenten erscheint eine Fehlermeldung.

Fehlermeldung

  • Fehler: modTelefonassistent.TeleSrvSetTapiDevice
    A3TAPI; Der Telefonserver ist momentan nicht erreichbar. Prüfen Sie bitte Ihre Netzwerkverbindung.--Nummer

Ursache

...

  • ERROR in 'SetDevice': lineOpen failed [0xFFFFFFFF80000047] Die Anwendung ist nicht für das Bearbeiten von Anforderungen registriert.

Ursache

  1. Die Netzwerkverbindung zwischen dem Arbeitsplatz und der Telefonanlage wurde unterbrochen.

Lösung

  1. Starten Sie den Arbeitsplatz neu - dadurch wird der TAPI-Treiber neugestartet - und prüfen Sie ob die Fehlermeldung beim Programmstart weiterhin erscheint.
    Dieser Schritt ist meist nur eine temporäre Lösung des Problems. Bei wiederholtem Auftreten ist es ratsam eine höhere Version des TAPI-Treibers zu installieren.
    Stellen Sie sicher, dass der TAPI-Treiber installiert und konfiguriert ist.
    Dazu können Sie per Windows Wählhilfe (dialer.exe) oder ADVOKAT Testprogramm "C:\Program Files (x86)\Advokat\A8TaTest.exe" versuchen eine Person anzurufen.Falls das Problem wiederholt auftritt, fahren Sie mit Punkt 2 fort.

  2. Navigieren Sie zur Datei "Kanzlei.cfg" im ADVOKAT Backend unter "...\ADVOKAT\Daten\Config". Es handelt sich dabei um eine Textdatei, öffnen Sie diese mit einem beliebigen Texteditor.
    Navigieren Sie zum Element Telefonie und löschen Sie die Zeile <TelComputer ...> für den betroffenen Anwender. 
    Beispiel, dieser Eintrag muss erweitert werden. Die Vorgehensweise ist abhängig davon ob alle Arbeitsplätze oder nur bestimmte Arbeitsplätze betroffen sind.

    Beispiel (Vorher)
    <Telefonie AmtPrefix="0" OrtsVorwahl="01" IntVorwahl="+43" KeineDeviceAnfrage="0" InitialUnterdrückteRufnummern="Anonym" Fehlend="VR" Flags="V;R" A8Tapi="0">
    <TelComputer Name="JD-PC" Device="Control ECSTA for Hipath 2000"/>
    <TelComputer Name="ADE-PC" Device="Control ECSTA for Hipath 3000"/>
    </Telefonie>

    a) Alle Arbeitsplätze betroffen
    Es wird das Attribut "ConnectionTimeout" für alle Arbeitsplätze ergänzt, der Wert ist in Millisekunden.
    In diesem Beispiel wird nach 5 Sekunden erneut die Verbindung zwischen Arbeitsplatz und Telefonanlage hergestellt.

    Beispiel (Nachher)
    <Telefonie AmtPrefix="0" OrtsVorwahl="01" IntVorwahl="+43" KeineDeviceAnfrage="0" ConnectionTimeOut="5000" InitialUnterdrückteRufnummern="Anonym" Fehlend="VR" Flags="V;R" A8Tapi="0">
    <TelComputer Name="JD-PC" Device="Control ECSTA for Hipath 2000"/>
    <TelComputer Name="ADE-PC" Device="Control ECSTA for Hipath 3000"/>

    </Telefonie>

    b) Bestimmte Arbeitsplätze betroffen
    Es wird das Attribut "ConnectionTimeout" für den Arbeitsplatz von Anwender "JD" ergänzt, der Wert ist in Millisekunden.
    In diesem Beispiel wird nach 3 Sekunden erneut die Verbindung zwischen Arbeitsplatz von Anwender "JD" und Telefonanlage hergestellt.

    Beispiel (Nachher)
    <Telefonie AmtPrefix="0" OrtsVorwahl="01" IntVorwahl="+43" KeineDeviceAnfrage="0" InitialUnterdrückteRufnummern="Anonym" Fehlend="VR" Flags="V;R" A8Tapi="0">
    <TelComputer Name="JD-PC" Device="Control ECSTA for Hipath 2000" ConnectionTimeOut="3000"/>
    <TelComputer Name="ADE-PC" Device="Control ECSTA for Hipath 3000"/>
    </Telefonie>

  3. Schließen Sie ADVOKAT und starten Sie es erneut, im Abfragefenster - wie im Bild ersichtlich - wählen Sie den passenden Eintrag aus der Dropdownliste aus.
    Dies ist erforderlich um den Benutzer und dessen Nebenstelle (Durchwahl) zu verbinden. Hinweis: Die Abfrage erscheint nicht, wenn nur ein Device zur Verfügung steht.
    Image Removeddas Programm erneut.