Versionen im Vergleich

Schlüssel

  • Diese Zeile wurde hinzugefügt.
  • Diese Zeile wurde entfernt.
  • Formatierung wurde geändert.

Ausgangssituation

  • Der Telefonassistent wurde erfolgreich eingerichtet

    und konnte bereits erfolgreich verwendet werden.Bei Programmstart von ADVOKAT erscheint keine Fehlermeldung, dennoch kann das Modul nicht verwendet werden

    .

  • Bei ein- oder ausgehenden Telefonaten wird bei der Nummer eine 0 zu viel oder zu wenig angezeigt.

Ursache

  1. Der

...

  1. Parameter "Flags" in der Konfigurationsdatei "Kanzlei.cfg"

...

  1. ist falsch.

Lösung

...

  1. Navigieren Sie

...

  1. per Windows Explorer zum ADVOKAT Backend unter "...\ADVOKAT\Daten\Config".

    • Öffnen Sie die Datei "Kanzlei.cfg" mit einem passenden Texteditor

...

<Telefonie ...>
<TelComputer Name="JD-PC" Device="123" Address="123"/>
<TelComputer Name="TEST-PC" Device="456" Address="456"/>
<TelComputer Name="MM-PC" Device="789" Address="789"/>
</Telefonie>

...

   

...

Navigieren Sie per Windows Explorer zum ADVOKAT Backend unter "...\ADVOKAT\Admin\Cab". Öffnen Sie die Datei "Features.xml" mit einem beliebigen Texteditor.
Stellen Sie sicher, dass in der Datei eine Zeile mit dem Kürzel="TEL1" existiert. Sollten Sie diesen Eintrag nicht finden, kontaktieren Sie den ADVOKAT Support telefonisch oder per E-Mail.

Info
titleBeispiel
<?xml version="1.0" encoding="utf-8"?>
<Features Version="1">
  <Feature Kürzel="TEL1" Datum="23.03.2021 12:50:38" FeatureEx="" />
</Features>

...

    • . Mehr Informationen dazu finden Sie im Kapitel Kanzlei.cfg.

    • Navigieren Sie zum Element Telefonie, es ist der Parameter "Flags" anzupassen. Die Beschreibung der einzelnen Attribute findet man im Kapitel Beschreibung der Attribute.

    • Szenario A: Es wird eine 0 zu viel angezeigt. Es ist das Flag 0 zu ergänzen, wie im Beispiel ersichtlich:

      • Beispiel (vorher)

        Codeblock
        languagexml
        <Telefonie AmtPrefix="0" OrtsVorwahl="01" IntVorwahl="+43" KeineDeviceAnfrage="0" InitialUnterdrückteRufnummern="Anonym" Fehlend="VR" Flags="V;R" A8Tapi="0">
        	<TelComputer Name="JD-PC" Device="Control ECSTA for Hipath 2000"/>
        </Telefonie>
      • Beispiel (nachher)

        Codeblock
        languagexml
        <Telefonie AmtPrefix="0" OrtsVorwahl="01" IntVorwahl="+43" KeineDeviceAnfrage="0" InitialUnterdrückteRufnummern="Anonym" Fehlend="VR" Flags="V;R;0" A8Tapi="0">
        	<TelComputer Name="JD-PC" Device="Control ECSTA for Hipath 2000"/>
        </Telefonie>

    • Szenario B: Es wird eine 0 zu wenig angezeigt. Es ist das Flag 0 zu entfernen, wie im Beispiel ersichtlich:

      • Beispiel (vorher)

        Codeblock
        languagexml
        <Telefonie AmtPrefix="0" OrtsVorwahl="01" IntVorwahl="+43" KeineDeviceAnfrage="0" InitialUnterdrückteRufnummern="Anonym" Fehlend="VR" Flags="V;R;0" A8Tapi="0">
        	<TelComputer Name="JD-PC" Device="Control ECSTA for Hipath 2000"/>
        </Telefonie>
      • Beispiel (nachher)

        Codeblock
        languagexml
        <Telefonie AmtPrefix="0" OrtsVorwahl="01" IntVorwahl="+43" KeineDeviceAnfrage="0" InitialUnterdrückteRufnummern="Anonym" Fehlend="VR" Flags="V;R" A8Tapi="0">
        	<TelComputer Name="JD-PC" Device="Control ECSTA for Hipath 2000"/>
        </Telefonie>
  1. Starten Sie ADVOKAT neu und testen Sie den Telefonassistent auf seine Funktionalität. Wiederholen Sie Schritt 1 mit den Flags 0A oder 0E anstatt 0, falls die Anzeige weiterhin falsch ist.
    Flag 0A wird verwendet falls nur ausgehende Telefonate und Flag 0E falls nur eingehende Telefonate betroffen sind. Siehe Kapitel Beschreibung der Attribute.