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Ausgangssituation

  • Der Programmstart von ADVOKAT dauert sehr lange.
  • Das Öffnen der Module Aktenverwaltung oder Dokumentverwaltung dauert sehr lange.
  • Die Verwendung des Suchassistenten und der dynamischen Suche dauert sehr lange.
  • Die Erstellung und/oder das Öffnen von Dokumenten (Beispiel: Word-Dokumente) über ADVOKAT dauert sehr lange.
  • Bei Verwendung der Dokumentvorschau in ADVOKAT erscheint das Fenster "Kopieren von ..." und ADVOKAT reagiert nicht.

Ursache
Es gibt mehrere mögliche Ursachen, es können auch mehrere gleichzeitig zutreffen:

  1. Der Datenbankserver ist veraltet, es fehlen Windows Updates.
  2. Der Datenbankserver ist zu stark ausgelastet.
  3. Die Microsoft SQL Instanzen für ADVOKAT am Datenbankserver sind hinsichtlich CPU und RAM zu streng limitiert.
  4. Die Anwender nutzen ADVOKAT auf einem externen Gerät welches per VPN-Tunnel in das Domänennetzwerk eingebunden ist.

Lösung

  1. Beschränken sich die Performanceprobleme auf das Öffnen von Akten, so versuchen Sie das Kapitel Öffnen von Akten beschleunigen umzusetzen, bevor Sie mit Schritt 2 fortfahren.

  2. Prüfen Sie ob ADVOKAT ohne Microsoft SharePoint verwendet wird. Mehr Informationen dazu finden Sie im Kapitel ADVOKAT mit Microsoft SharePoint.
    Bei der Verwendung von ADVOKAT mit Microsoft SharePoint wechseln Sie zum Kapitel ADVOKAT mit Microsoft SharePoint - Performanceprobleme.

  3. Stellen Sie am Datenbank- sicher, dass alle verfügbaren Windows Updates für Microsoft SQL eingespielt sind.

  4. Stellen Sie am Datenbankserver sicher, dass die CPU-, RAM- und Datenträgerauslastung nicht konstant höher als 80% sind.
    Es müssen genügend freie Ressourcen für Betriebssystem von Microsoft SQL Server und zur Verfügung stehen.

  5. Stellen Sie sicher, dass ADVOKAT nicht auf externen Geräten außerhalb des Domänennetzwerks per VPN-Tunnel verwendet wird.
    • Wir raten von dem Betrieb auf externen Geräten per VPN-Tunnel ab, die Performance leidet zu stark darunter. Bei Verwendung von Microsoft SharePoint potenzieren sich solche Performanceprobleme.
    • Stattdessen ist ADVOKAT auf Arbeitsstationen oder Terminalservern innerhalb des Domänennetzwerks zu verwenden, siehe Kapitel Hinweise.

  6. Passen Sie die Konfiguration am Datenbankserver per Microsoft SQL Management Studio für die relevante Microsoft SQL Instanz an:
    • Servereigenschaften > Arbeitsspeicher
      • Mindestmenge an Serverarbeitsspeicher (in MB): Dieser Wert ist zu erhöhen, etappenweise um 2048 MB.
      • Maximaler Serverarbeitsspeicher (in MB): Dieser Wert ist zu erhöhen, etappenweise um 2048 MB, maximal 80% des verfügbaren Arbeitsspeichers.

  7. Dieses Kapitel befindet sich im Aufbau...

  8. Öffnen Sie am Datenbankserver den SQL Server Konfigurationsmanager und wechseln Sie in den Reiter "SQL Server-Netzwerkkonfiguration".
    Ist das Protokoll "Named Pipes" aktiviert, dann deaktivieren Sie es. Ist das Protokoll deaktiviert, dann aktivieren Sie dieses.

    Wiederholen Sie diesen Schritt für die andere SQL-Instanz, falls die Datenbanken von ADVOKAT und Microsoft SharePoint auf zwei Instanzen aufgeteilt sind.
    Beachten Sie, dass für diese Änderung ein Neustart der Microsoft SQL Instanzen erforderlich ist.

  9. Stellen Sie sicher, dass am File- und Datenbankserver die verwendete Lösung zur Sicherung der Daten und/oder eine Serverreplikation diese Maschinen nicht zu stark auslastet.
    Im Zweifelsfall sind Datensicherung und Replikation zeitlich so abzuändern, dass diese außerhalb der Arbeitszeiten der Anwender erfolgen.

  10. Helfen die vorigen Schritte nicht und man nimmt weiterhin an, dass der Datenbankserver die Performanceprobleme verursacht, so müssen dieser Maschine weitere Ressourcen (CPU-Kerne und Arbeitsspeicher) zugewiesen werden.
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