Zum Ende der Metadaten springen
Zum Anfang der Metadaten

Sie zeigen eine alte Version dieser Seite an. Zeigen Sie die aktuelle Version an.

Unterschiede anzeigen Seitenhistorie anzeigen

« Vorherige Version anzeigen Version 14 Nächste Version anzeigen »

Ausgangssituation

  • Bei der Installation laut Kapitel 8.3 Installation, Punkt 1 erscheint beim Klick "OK (Einstellungen speichern und ggf. Zertifikat installieren)" eine der untenstehenden Fehlermeldungen.
  • Im Protokoll "ADVOKATRestService$<Name>$<Name>-Nummer.log" im ADVOKAT Backend unter "...\ADVOKAT\Daten\Log", erscheint eine der untenstehenden Fehlermeldungen.

Beispiele (Fehlermeldungen)

  • Fehler beim Prüfen des Root-Zertifikates: Der Zugriff auf den Pfad "C:\Program Files (x86)\Advokat\CA.pfx" wurde verweigert.
  • Fehler beim Prüfen des Root-Zertifikates: Der Zugriff wurde verweigert.
  • Fehler in der Webserviceroutine => App failing...System.ServiceModel.AddressAccessDeniedException: HTTP konnte URL "https://+:8000/AdvService/" nicht registrieren. Der Prozess weist keine Zugriffsrechte für diesen Namespace auf.

Ursache

  1. Dem Serviceaccount für AdvoAll fehlen lokale administrative Rechte.
  2. Die Benutzerkontensteuerung (UAC) des Betriebssystems blockiert trotz lokaler administrativer Rechte den Zugriff.

Lösung

  1. Stellen Sie sicher, dass der Serviceaccount, welcher für AdvoAll genutzt wird, am AdvoAll-Gerät ober lokale administrative Rechte verfügt.

  2. Navigieren Sie auf zum ADVOKAT Frontend unter "C:\Program Files (x86\Advokat)" und starten Sie "AdvoAll.exe". Markieren Sie den Eintrag "ADVOKATRestService" > "Bearbeiten" > "Konfiguration bearbeiten".
    Klicken Sie im Fenster "ADVOKAT RestService Setup" auf OK, um sicherzustellen, dass nicht die Meldung "Fehler beim Prüfen des Root-Zertifikats: Zugriff verweigert" erscheint. 
    Tritt das Problem weiterhin auf, fahren Sie mit Schritt 3 fort.

  3. Öffnen Sie den Registrierungseditor (regedit) und navigieren Sie zu: [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\SystemCertificates]
    Per Rechtsklick > "Berechtigungen" geben Sie dem Serviceaccount von AdvoAll "Vollzugriff". Wiederholen Sie Schritt 2, tritt das Problem weiterhin auf, fahren Sie mit Schritt 4 fort.

  4. Öffnen Sie den Registrierungseditor (regedit) und navigieren Sie zu: [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Policies\System\]
  • Keine Stichwörter