11.6.3 Berechtigungen für Domänenadministrator fehlen

Ausgangssituation

  • Die Filesecurity ist eingerichtet, der/die Domänenadministrator(en) haben keinen Zugriff auf alle oder bestimmte Unterordner (Akten) unter “…\ADVOKAT\Daten\Winword”.

Ursache

Die Filesecurity berechtigt unter “…\ADVOKAT\Daten\Winword” in den Unterordnern (Akten) exakt jene Benutzer (Domänenkonten), welche laut Securitymodul definiert sind.
Gibt es in ADVOKAT keinen Benutzer, welcher an den Domänenadministrator gekoppelt und folglich in der Security bei Aktengruppen zugelassen ist, dann hat der Domänenadministrator auch keinen Zugriff.

Lösung

  1. Kontaktieren Sie einen Securityadministrator in Ihrem Unternehmen. Eine Liste der Securityadministratoren finden Sie in ADVOKAT per Menüpunkt "?" > "Info".

    • Im Infofenster im ersten Absatz werden die Administratoren in der Zeile (Administratoren: ....) aufgelistet.

    • Beachten Sie, dass der ADVOKAT Support nicht befugt ist die Einstellungen des Securitymodul auszuhebeln oder das Modul zu deaktivieren.

  2. Der Securityadministrator navigiert in ADVOKAT zu Menüpunkt "Programme" > "Tabellen warten" > "Benutzer und Gruppen".

    1. Im Reiter “Benutzer” wird per Schaltfläche “Neu” ein neuer Benutzer mit Namen “Administrator” oder ähnlich angelegt.

      • Als Typ wird “SB” (Sachbearbeiter) ausgewählt und im Feld “Windows Benutzer” wird der zugehörige Domänenadministrator ausgewählt.

      • Gibt es mehrere Domänenadministratoren, dann wiederholen Sie diesen Schritt.

    2. Im Reiter “Gruppen” werden diese Administratoren-Benutzer zur Gruppe “Administratoren” hinzugefügt.

  3. Der Securityadministrator navigiert in ADVOKAT zu Menüpunkt "Programme" > "Tabellen warten" > "Security".

    • Im Reiter “Akten” wird bei jeder Aktengruppe sichergestellt, dass die Benutzergruppe “Administratoren” das Securityrecht “Akt sehen” zugelassen hat.

    • Warten Sie nun bis zu 24 Stunden ab, bis die Filesecurity die Änderungen im Dateisystem umgesetzt hat. Möchten Sie nicht warten, dann fahren Sie mit Schritt 4 fort.

  4. Verbinden Sie sich mit dem ADVOKAT Serviceaccount von AdvoAll (im Regelfall lautet dieser "svc_advokat") per Remotedesktop auf das betroffene Gerät.

    • Den Gerätenamen können Sie den Fehlermeldungen beim Programmstart oder den Dateinamen von AdvoAll im ADVOKAT Backend unter "...\ADVOKAT\Daten\Config\AdvoAll" entnehmen.

    • Beispiel: SERVER$svc_advokat$AdvoAllService.status

       

  5. Öffnen Sie die Diensteverwaltung und starten Sie den Dienst "AdvoAll" neu. Es wird der Dienst "AdvoAll" beendet und es startet automatisch "AdvoAllUpdateService".
    Dieser Dienst wird nach kurzer Zeit beendet und es startet wieder "AdvoAll". Durch den Neustart von AdvoAll wird der neue Benutzer erzwungenermaßen erkannt.

  6. Navigieren Sie per Windows Explorer zu "C:\Program Files (x86)\Advokat" und starten Sie die AdvoAll-Benutzeroberfläche per "AdvoAll.exe".
    Stellen Sie sicher, dass bei der AdvoAll-Anwendung "ADVOKAT_Filesecurity" in der Spalte Status "Aktiv <Uhrzeit>" steht. Bei Problemen mit AdvoAll selbst wechseln Sie zum Kapitel AdvoAll Fehlerbehandlung.

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