Ausgangssituation
- ADVOKAT wird gemeinsam mit Microsoft SharePoint eingesetzt.
- Es kommt bei Verwendung der Funktionen "Dokumentbibliothek neu zuweisen", "Einstellungen korrigieren", "Security korrigieren" im SharePoint-Tool "Advokat8.DMS.Sharepoint.Manager.exe" zu einer Fehlermeldung.
Beispiele (Fehlermeldungen)
- 2022-12-15 08:48:47.859 +01:00 [ERR] ( 3, Advokat8.DMS.Sharepoint.Manager.SharepointContext.SharepointListCreator) Could not add user '<DOMÄNE>\<DOMÄNENKONTO>' to Sharepoint
Microsoft.SharePoint.SPException: Der angegebene Benutzer <DOMÄNE>\<DOMÄNENKONTO> wurde nicht gefunden.
bei Microsoft.SharePoint.SPWeb.EnsureUser(String logonName)
bei Advokat8.DMS.Sharepoint.Manager.SharepointContext.SharepointListCreator.FillGroupsWithUsers(IProgress`1 progress)
Ursache
Das SharePoint-Tool wird mit einem Windows Benutzerkonto ausgeführt, welches nicht über alle erforderlichen Berechtigungen seitens Microsoft SharePoint verfügbar.
Dies kann auch zutreffen, wenn es sich beim Windows Benutzerkonto um einen SharePoint Farmadministrator handelt.
Lösung
- Beenden Sie das SharePoint-Tool in der vorhandenen RDP-Sitzung am SharePoint-Server.
- Verbinden Sie sich per Remotedesktop auf den Microsoft SharePoint-Server, als Windows Benutzerkonto muss jener SharePoint Administrator gewählt werden unter dem Microsoft SharePoint initial installiert wurde.
Stellen Sie sicher, dass unter diesem Windows Benutzerkonto das ADVOKAT Netzlaufwerk ebenfalls eingebunden ist. - Öffnen Sie per Windows Explorer das ADVOKAT Backend unter "...\ADVOKAT\Admin\Support\Adv2SharePoint" und starten das Tool "Advokat8.DMS.SharePoint.Manager.exe" erneut.
Wechseln Sie retour zum Kapitel wo der weitere Ablauf für die Funktion "Dokumentbibliothek neu zuweisen", "Einstellungen korrigieren" oder "Security korrigieren" beschrieben ist.