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Problemstellung
Sobald man ein Dokument in ADVOKAT basierend auf einer bestimmten Vorlage erstellt retourniert das Programm eine Fehlermeldung und es wird kein Dokument erzeugt.

Beispiele (Fehlermeldungen)

  • Fehler: WWBefehl0Microsoft Word; Fehler beim Verarbeiten der XML-Datei 'Dateiname' in Word.
    Der im Endtag des Elements enthaltene Name muss mit dem Elementtyp im Starttag übereinstimmen.Position: Komponente: /word/document.xml, Zeile: <Nummer>, Spalte <Nummer>-<Nummer>

  • Fehler: WWBefehl0Microsoft Word; Fehler beim Verarbeiten der XML-Datei 'Dateiname' in Word.
    Der im Endtag des Elements enthaltene Name muss mit dem Elementtyp im Starttag übereinstimmen.Position: Komponente: /word/header3.xml, Zeile: <Nummer>, Spalte <Nummer>-<Nummer>

  • Fehler: WWBefehl0Microsoft Word; Fehler beim Verarbeiten der XML-Datei 'Dateiname' in Word.
    Der im Endtag des Elements enthaltene Name muss mit dem Elementtyp im Starttag übereinstimmen.Position: Komponente: /word/footer3.xml, Zeile: <Nummer>, Spalte <Nummer>-<Nummer>

Ursache

  • Ein Stoppcode ist falsch angegeben, es fehlt beispielsweise die Raute (#) vor oder nach der Zahl.

  • Es wird ein Stoppcode in der Vorlage verwendet, welcher nicht dafür geeignet ist.

  • Ein XML-Element oder eine Bedingung ist nicht korrekt geschlossen.

  • Es wird auf einen Briefkopf, Brieffuß oder Kanzleistempel verweisen, dessen Datei defekt ist oder einen Inhalt hat, welcher nicht von ADVOKAT unterstützt wird.

Lösung

  1. Prüfen Sie bei allen Stoppcodes, ob die Raute vor und nach der Zahl angegeben ist. Zwischen Raute und Zahl darf kein Leerzeichen oder sonstiger Text vorkommen.

  2. Prüfen Sie für jeden verwendeten Stoppcode in der Programmhilfe (F1) von ADVOKAT, ob die Verwendung erlaubt ist.
    Beachten Sie zusätzlich bei folgenden Stoppcodes, ob diese in eine Tabelle eingebettet sind:

    • #131#, #131a#, #131f#

    • #132#, #132a#, #132f#

    • #600#, #601#, #604#, #606#

  3. Bei der Fehlermeldung mit dem Wortlaut document.xml ist das Problem im Dokumentinhalt zu suchen.
    Kopf- und Fußzeile mit einem Stoppcode wie beispielsweise #807# können als Fehlerquelle ausgeschlossen werden.

    • Entfernen Sie alle existierenden Tabellen und fügen Sie diese neu ein.

    • Entfernen Sie Schritt für Schritt einzelne Stoppcodes und fügen Sie diese neu ein.

    • Bei Schriftsatzvorlagen ist zusätzlich zu prüfen, ob der Kanzleistempel aufgrund der Stoppcodes #131*# und #132*# korrekt eingefügt werden kann.

      • Verschieben Sie also die Dateien "RA.*" unter "...\ADVOKAT\Daten\WW\BK" testweise in einen neu erstellen Ordner "Sicherung".

  4. Bei der Fehlermeldung mit dem Wortlaut header3.xml ist das Problem bei einem Stoppcode wie beispielsweise #807# oder #807d# in der Kopfzeile der Vorlage zu suchen.

    • Öffnen Sie also die betroffene Vorlage und entfernen Sie den Stoppcode in der Kopfzeile auf der ersten Seite.

    • Erstellen Sie das Dokument erneut, tritt das Problem nicht mehr auf- so ist die Briefkopfdatei "BK1.DOCX/RTF" unter "...\ADVOKAT\Daten\WW\BK" nicht in Ordnung.

    • Wiederholen Sie den Schritt für den Stoppcode in der Kopfzeile auf der zweiten Seite. In diesem Fall ist die Datei "BK2.rtf" nicht in Ordnung.

      • Es wäre auch möglich, dass beide Dateien nicht Ordnung sind, also beide Stoppcodes testweise entfernt werden müssen.

  5. Bei der Fehlermeldung mit dem Wortlaut footer3.xml ist das Problem bei einem Stoppcode wie beispielsweise #807# oder #807d# in der Fußzeile der Vorlage zu suchen.

    • Öffnen Sie also die betroffene Vorlage und entfernen Sie den Stoppcode in der Fußzeile auf der ersten Seite.

    • Erstellen Sie das Dokument erneut, tritt das Problem nicht mehr auf, so ist die Brieffußdatei "BF1.rtf" unter "...\ADVOKAT\Daten\WW\BK" nicht in Ordnung. 

    • Wiederholen Sie den Schritt für den Stoppcode in der Fußzeile auf der zweiten Seite. In diesem Fall ist die Datei "BF2.rtf" nicht in Ordnung.

      • Es wäre auch möglich, dass beide Dateien nicht Ordnung sind, also beide Stoppcodes testweise entfernt werden müssen.

  6. Wurde bei Schritt 3 bis 5 festgestellt, dass die Datei RA.DOCX/RTF, BK1.DOCX/RTF, BK2.DOCX/RTF, BF1.DOCX/RTF oder BF2.DOCX/RTF die Fehlermeldung hervorrufen, so sind diese Dateien neu zu erstellen.
    Befolgen Sie bei der Neuerstellung unbedingt die Schritte laut Kapitel Briefpapier und Kanzleistempel.

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