1.12.7.5.3 Akten (Dokumente) weiterhin in SharePoint

Ausgangssituation

  • Es wurde die Durchführung der Migration wie beschrieben vorgenommen und es sind keine Probleme (Fehlermeldungen) aufgetreten.

  • Trotzdem gibt es weiterhin Akten bzw. in Akten Dokumente, welche sich in einer SharePoint Dokumentbibliothek befinden.

    • Die Dokumente wurden nicht retour in das Windows-Dateisystem migriert.

    • Solche Dokumente erkennt man daran, dass im Feld “Datei” weiterhin ein Pfad zu Microsoft SharePoint zeigt.

Ursachen

  • Bei der Migration konnten diese Dokumente nicht bearbeitet werden. Die Dateien waren von einem Anwender geöffnet oder die Antivirensoftware hat zwecks Überprüfung darauf zugegriffen.

  • Bei der Migration konnten diese Dokumente nicht geöffnet werden, da der SharePoint-Administrator in dessen Kontext die Migration durchgeführt wurde darauf keinen Zugriff hat.

  • Bei der Migration wurde festgestellt, dass diese Dokumente nicht unter dem laut ADVOKAT gespeicherten Pfad in SharePoint vorhanden sind.

    • Dokumente wurden außerhalb von ADVOKAT (Windows Explorer, Internet Browser) umbenannt, gelöscht oder verschoben.

    • Die Ordner in denen die Dokumente enthalten sind wurden außerhalb von ADVOKAT (Windows Explorer, Internet Browser) umbeannt, gelöscht oder verschoben.

Lösung

  1. Stellen Sie sicher, dass am SharePoint-Server der Windows Dienst “WebClient” installiert und der Starttyp “Automatisch” gesetzt ist. Details dazu finden Sie im Kapitel Voraussetzungen, Punkt 3.

    • Stellen Sie zusätzlich dazu sicher, dass vom Dienst “WebClient” die automatische Anmeldung an Microsoft SharePoint On-Premise auch tatsächlich funktioniert.

    • Alle notwendigen Informationen dazu finden Sie im Kapitel WebDAV (WebClient) verlangt Anmeldeinformationen.

    • Führen Sie Schritt 1 bis 5 laut Kapitel Durchführung erneut durch, schlägt diese wieder fehl dann fahren Sie mit Schritt 2 fort.

  2. Starten Sie ADVOKAT am SharePoint-Server und stellen sicher, dass es unter Menüpunkt "Programme" > "Tabellen warten" > "Security" > Reiter "Akten":

    • Keine Aktengruppen gibt, bei denen das Recht "Akt sehen (erfordert SQL-Server)" für den ADVOKAT Benutzer verweigert ist, mit dem das Domänenkonto des SharePoint-Administrator verknüpft ist.

    • Bei Aktengruppe “Standard-Akten-Gruppe” und “Alle Akten” bei denen das Recht "Akt sehen (erfordert SQL-Server)" für den ADVOKAT Benutzer verweigert ist, mit dem das Domänenkonto des SharePoint-Administrator verknüpft ist.

      • Die Verknüpfung zwischen ADVOKAT Benutzer und Domänenkonto ist unter Menüpunkt “Programme” > “Tabellen warten” > “Benutzer und Gruppen” beim Benutzer im Feld "Windows Benutzer" ersichtlich.

  3. Starten Sie ADVOKAT am SharePoint-Server und drücken am Startbildschirm "STRG + SHIFT + Doppelklick linke Maustaste".

    • Wählen Sie im Menü die Option "Akten-Security berichtigen", es öffnet sich der Suchassistent. Geben Sie keine Suchkriterien ein sondern klicken Sie direkt auf "Suchen" und anschließend auf "OK".

    • ADVOKAT versucht die Berechtigungen in Microsoft SharePoint On-Premise vollautomatisch zu korrigieren.

    • Führen Sie erneut Schritt 1 bis 5 laut Kapitel Durchführung erneut durch, schlägt diese wieder fehl dann fahren Sie mit Schritt 4 fort.

  4. Stellen Sie sicher, dass der verwendete Domänenbenutzer tatsächlich der "SharePoint-Administrator" ist die Berechtigungen in SharePoint korrekt sind.

    • Führen Sie dazu Schritt 3 bis 9 laut Kapitel Änderungen im Securitymodul funktionieren nicht durch.

      • Mögliche Ursache ist, dass der falsche Benutzer gewählt wurde, also ein Benutzer der nicht über alle erforderlichen administrativen Rechte verfügt.

      • Der SharePoint-Administrator muss wie bei der initialen Migration auf Microsoft SharePoint über Vollzugriff in SharePoint verfügen.

      • Mit Vollzugriff ist gemeint, dass dieser Benutzer als "Websitesammlungsadministrator" (SiteCollection-Administrator) definiert ist.

  5. Führen Sie erneut Schritt 1 bis 5 laut Kapitel Durchführung erneut durch, schlägt diese wieder fehl dann definieren Sie den "SharePoint-Administrator" zusätzlich als SharePoint Farmadministrator.
    Nachdem der "SharePoint-Administrator" nun Websitesammlungsadministrator und Farmadministrator ist versuchen Sie die Migration wieder.

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