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8.6.6 Zugriffsrechte fehlen

8.6.6 Zugriffsrechte fehlen

Ausgangssituation

  • Bei der Installation laut Kapitel Installation, Punkt 1 erscheint beim Klick "OK (Einstellungen speichern und ggf. Zertifikat installieren)" eine der untenstehenden Fehlermeldungen.

  • Im Protokoll "ADVOKATRestService$<Name>$<Name>-Nummer.log" im ADVOKAT Backend unter "...\ADVOKAT\Daten\Log", erscheint eine der untenstehenden Fehlermeldungen.

Beispiele (Fehlermeldungen)

  • Fehler beim Prüfen des Root-Zertifikates: Der Zugriff auf den Pfad "C:\Program Files (x86)\Advokat\CA.pfx" wurde verweigert.

  • Fehler beim Prüfen des Root-Zertifikates: Der Zugriff wurde verweigert.

  • Fehler in der Webserviceroutine => App failing...System.ServiceModel.AddressAccessDeniedException: HTTP konnte URL "https://+:8000/AdvService/" nicht registrieren.
    Der Prozess weist keine Zugriffsrechte für diesen Namespace auf.

  • Fehler in der Webserviceroutine => App failing...
    System.ArgumentNullException: Der Wert darf nicht NULL sein.

Ursache

  1. Dem AdvoAll-Benutzerkonto (üblicherweise “Domäne\svc_advokat”) fehlen lokale administrative Rechte.

  2. Die Benutzerkontensteuerung (UAC) des Betriebssystems blockiert trotz lokaler administrativer Rechte den Zugriff.

Lösung

  1. Stellen Sie sicher, dass das AdvoAll-Benutzerkonto am AdvoAll-Gerät über lokale administrative Rechte verfügt.
    Stellen Sie sicher, dass Sie am AdvoAll-Gerät nicht als Domänenadministrator sondern mit dem AdvoAll-Benutzerkonto im Zuge der Installation angemeldet sind.

  2. Navigieren Sie zum ADVOKAT Client (Frontend) unter "C:\Program Files (x86\Advokat)" und starten Sie "AdvoAll.exe". Markieren Sie den Eintrag "ADVOKAT_Mobile" > "Bearbeiten" > "Konfiguration bearbeiten".

    • Klicken Sie im Fenster "ADVOKAT RestService Setup" auf OK, um sicherzustellen, dass das Fenster reagiert und keine Fehlermeldung erscheint.

    • Tritt das Problem weiterhin auf, fahren Sie mit Schritt 3 fort.

  3. Starten Sie das Befehlszeilenkommando (CMD) per Rechtsklick > "Als Administrator ausführen".

    • Fügen Sie das Netzlaufwerk von ADVOKAT im Kontext des Standard-Administrator hinzu, damit dieses trotz aktiver Benutzerbenutzerkontensteuerung (UAC) gefunden wird.

      • Beispiel: net use S: \\FILESERVER\ADVOKAT /persistent:yes

    • Wiederholen Sie Schritt 2, tritt das Problem weiterhin auf, fahren Sie mit Schritt 4 fort.

  4. Öffnen Sie den Registrierungseditor (regedit) am AdvoAll-Gerät in der Windows-Sitzung des AdvoAll-Benutzerkontos und navigieren Sie zu beiden Pfaden:

    • [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\SystemCertificates]

    • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SystemCertificates\Root]

    • Per Rechtsklick > "Berechtigungen" geben Sie dem AdvoAll-Benutzerkonto jeweils in beiden Verzeichnissen "Vollzugriff".

    • Wiederholen Sie Schritt 2, tritt das Problem weiterhin auf, fahren Sie mit Schritt 5 fort.
       

  5. Navigieren Sie erneut per Windows Explorer zum Verzeichnis "C:\Program Files (x86)\Advokat". Führen Sie per Rechtsklick > "Als Administrator ausführen" die Datei "AdvoAll.exe" aus.

    • Markieren Sie den Eintrag "ADVOKAT_Mobile" > "Bearbeiten" > "Konfiguration bearbeiten".

    • Klicken Sie im Fenster "ADVOKAT RestService Setup" auf OK, um sicherzustellen, dass das Fenster reagiert und keine Fehlermeldung erscheint.

  6. Öffnen Sie den Registrierungseditor (regedit) und navigieren Sie zu: [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Policies\System\]

    • Setzen Sie beim Eintrag "EnableLUA" vom Typ "REG_DWORD" den Wert auf "0". Starten Sie das Gerät neu und versuchen zuerst Schritt 2, dann Schritt 5.

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