5.7.2 AdvoAll funktioniert sporadisch nicht

Ausgangssituation

  • Es ist eine AdvoAll Anwendung im Einsatz.
  • Die AdvoAll Anwendungen funktionieren sporadisch nicht, es kommt in den Protokollen im Verzeichnis "%programdata%/Advokat" zu Fehlermeldungen.

Beispiele (Fehlermeldungen)

  • Ein Teil des Pfades "...\Advokat\Daten\Config\AdvoAll\" konnte nicht gefunden werden.
  • Die zugrunde liegende Verbindung wurde geschlossen: Unerwarteter Fehler beim Senden.
  • Fehler beim Initialisieren der Advokat-Komponenten (Bestand '...\Advokat\Daten\Advokat.ini', Vz '...\Advokat\Scan_Import'...

Ursache

Für den reibungslosen Betrieb von AdvoAll wird eine unterbrechungsfreie Verbindung des Netzlaufwerkes am AdvoAll-Gerät benötigt.
Aufgrund von beispielsweise Netzwerkproblemen oder Windows Updates kann es zu Unterbrechungen kommen.

Lösung

  1. Verbinden Sie sich mit dem AdvoAll-Benutzerkonto (im Regelfall lautet dieses "Domäne\svc_advokat") per Remotedesktop auf das betroffene Gerät.
    Den Gerätenamen können Sie den Fehlermeldungen beim Programmstart oder den Dateinamen von AdvoAll im ADVOKAT Backend unter "...\ADVOKAT\Daten\Config\AdvoAll" entnehmen.

    Beispiel

    SERVER$svc_advokat$AdvoAllService.status

       

  2. Stellen Sie sicher, dass das Netzlaufwerk für das ADVOKAT Backend persistent verbunden ist und nicht der Status "Unvollständig" oder "Nicht verbunden" vorliegt.
    Ob ein Netzlaufwerk persistent verbunden ist, erkennen Sie daran, dass im Registrierungseditor ein Eintrag unter [HKEY_CURRENT_USER\Network\] existiert, welcher den Buchstaben des Netzlaufwerks trägt.

  3. Führen Sie das Befehlszeilenkommando (cmd) per Rechtsklick > "Als Administrator ausführen" aus und fügen Sie das Netzlaufwerk von ADVOKAT im Kontext des Standard-Administrator hinzu.

    Beispiel

    net use S: \\FILESERVER\ADVOKAT /persistent:yes
  4. Stellen Sie sicher, dass sich das ADVOKAT Frontend (Client) erfolgreich starten lässt. Navigieren Sie dazu zu "...\ADVOKAT\" im ADVOKAT und starten Sie "Advokat.exe".
    Hinweis: Erscheint die Meldung "Es sind bereits alle Lizenzen verbraucht" kann diese mit Klick auf "OK" ignoriert werden.

  5. Navigieren Sie per Windows Explorer zum ADVOKAT Backend unter "...\ADVOKAT\Daten". Stellen Sie sicher, dass im Unterordner "Config" die Rechte laut Kapitel Anforderungen Berechtigungen gesetzt sind.

    • Sie können dies verifizieren indem Sie in dem Unterordner "Config" eine Testdatei "Test.txt" erstellen, öffnen, bearbeiten und anschließend löschen. All diese Vorgänge müssen funktionieren.

  6. Wiederholen Sie im Unterordner "AdvoAll" von "Config", also unter "...\ADVOKAT\Daten\Config\AdvoAll" die Überprüfung der erforderlichen Rechte und den Test per "Test.txt".

    • Stellen Sie außerdem sicher, dass für die Datei “…\ADVOKAT\Daten\Config\AdvoAll\Versions.xml” das Dateiattribut “Schreibgeschützt” (Read-only) deaktiviert ist.

    • Öffnen Sie die Datei "Versions.xml" mit einem passenden Texteditor. Mehr Informationen dazu finden Sie im Kapitel Datei "Versions.xml".

      • Stellen Sie sicher, dass in der Zeile mit dem Computernamen des AdvoAll-Gerätes der Parameter "Version" enthalten ist.
      • Fehlt der Parameter in dieser Zeile, dann fügen Sie diesen wie im Beispiel ersichtlich hinzu. Als Versionsnummer geben Sie jene Nummer an, die beim Parameter "CurrentVersion" enthalten ist.

        Beispiel (falsch)Beispiel (richtig)
        <?xml version="1.0" encoding="windows-1252"?>
        <Versions CurrentVersion="6.2701.0.9" InstallationsZeitpunkt="01.01.2024 00:00:00">
        <Version Computer="SERVER" AutoUpdate="1"/>
        </Versions>
        <?xml version="1.0" encoding="windows-1252"?>
        <Versions CurrentVersion="6.2701.0.9" InstallationsZeitpunkt="01.01.2024 00:00:00">
        <Version Computer="SERVER" AutoUpdate="1" Version="6.2701.0.9"/>
        </Versions>

        Bei Fragen oder Unklarheiten dazu kontaktieren Sie bitte den ADVOKAT Support per E-Mail unter support@advokat.at oder telefonisch per +43 512 / 58 80 33.
           

  7. Navigieren Sie zum ADVOKAT Backend unter "...\ADVOKAT\Daten\Config\AdvoAll" und öffnen Sie die Datei "AdvoAll.cfg" mit einem passenden Texteditor.
    Mehr Informationen zur Datei finden Sie im Kapitel Datei "AdvoAll.cfg". Suchen Sie nach der Zeile <AdvoAll> und ergänzen Sie den Parameter LogLevel="Debug".

    Beispiel (Vorher)Beispiel (Nachher)

    <?xml version="1.0" encoding="Windows-1252"?>
    <AdvoAll>
      ...
    </AdvoAll>

    <?xml version="1.0" encoding="Windows-1252"?>
    <AdvoAll LogLevel="Debug"/>
      ...
    </AdvoAll>

    Dadurch findet eine erweitere Protokollierung unter "...\ADVOKAT\Daten\Log\AdvoAll" statt. Mehr Informationen dazu finden Sie hier.

  8. Stellen Sie sicher, dass Windows Updates nur während eines Wartungsfensters und nicht im laufenden Betrieb eingespielt werden.
    • Dies gilt insbesondere wenn AdvoAll auf einem Desktopbetriebssystem (Windows 10 und Windows 11) zum Einsatz kommt.
    • Werden Windows Updates entgegen dieser Empfehlung eingespielt, so ist nach der Einspielung darauf zu achten, dass das Gerät oder zumindest der Dienst "AdvoAll" neugestartet wird.

  9. Öffnen Sie am AdvoAll-Gerät die Diensteverwaltung. Markieren Sie den Eintrag "AdvoAll-Dienst" > Rechtsklick > "Eigenschaften". Wechseln Sie in den Reiter "Wiederherstellung".

    Wählen Sie beim Feld "Erster Fehler" die Option "Dienst neu starten" und geben Sie im Feld "Dienst nach" einen Wert von "5" Minuten an.


  10. Hilft Schritt 9 mit einem Zeitintervall von 5 Minuten nicht, so versuchen Sie es erneut mit 10, 15, 30 oder 60 Minuten.
    Zusätzlich ist bei den Optionen "Zweiter Fehler" und "Weitere Fehler" die Option "Dienst neustarten" zu wählen.

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