4.1.10.11 Fehlermeldung '(414) REQUEST URI TOO LONG'

Ausgangssituation

  • ADVOKAT wird gemeinsam mit Microsoft SharePoint eingesetzt.

  • Beim Erstellen von Dokumenten in ADVOKAT tritt eine bestimmte Fehlermeldung auf.

  • Beim Drag & Drop von Dokumenten in einen ADVOKAT Akt tritt eine bestimmte Fehlermeldung auf.

Beispiele (Fehlermeldungen)

  • ADVOKAT - UCAktVerwaltungAkt.PasteDrop
    Der Remoteserver hat einen Fehler zurückgegeben: (414) REQUEST URI TOO LONG.

  • ADVOKAT - UCAktVerwaltungAkt.PasteDrop
    The remote server returned an error: (414) REQUEST URI TOO LONG.

Ursache

Microsoft SharePoint retourniert diese Fehlermeldung an ADVOKAT retour, wenn der Dateiname länger ist als in Microsoft SharePoint erlaubt.
Es gibt in Microsoft SharePoint eine Reihe von Limitierungen zu denen auch die maximale Länge des Dateinamens zählt, siehe Kapitel Zeichenanzahl Ordner und Dokumente.

Lösung

  1. Navigieren Sie in ADVOKAT zum Menüpunkt "System" > "Einstellungen" > Reiter "Dokumente" > Schaltfläche "Weitere Einstellungen" > Reiter "Verzeichnisse" > Schaltfläche "Einstellungen für Dokumentablage bearbeiten".
    Alle notwendigen Informationen zu diesem Fenster finden Sie im Kapitel Einstellungen Dokumentablage bei Microsoft SharePoint.

  2. Im Bereich "MS-SharePoint Dokumentenmanagement" stellen Sie sicher, dass im Feld "Maximale Dateinamenlänge" der Wert 100 konfiguriert ist.
    Ist der Wert bereits 100, dann können Sie diesen Schritt ignorieren. Ist der Wert höher als 100, dann ändern Sie diesen auf 100 und bestätigen mit "OK".

  3. Stellen Sie sicher, dass auf allen Arbeitsplätzen ADVOKAT und Microsoft Office Outlook geschlossen und erneut gestartet wird

    • Testen Sie anschließend erneut die ursprüngliche Aktion (Erstellen von Dokument, Drag & Drop von Dokument) im selben Akt.

    • Tritt das Problem weiterhin auf, dann wechseln Sie zu Schritt 4.

  4. Stellen Sie sicher, dass ADVOKAT Version 6.25g oder höher verwendet wird. Im Bedarfsfall führen Sie ein ADVOKAT Update durch, siehe Kapitel ADVOKAT Update.
    Welche Version im Einsatz ist kann per Menüpunkt "?" > "Info" in der Zeile "Programmversion" ermittelt werden.

Copyright © 2024 ADVOKAT Unternehmensberatung GREITER & GREITER GmbH - Impressum ->https://advokat.at/Impressum.aspx