4.1.10.9.1 Fehlermeldung 0x80070005

Ausgangssituation

  • ADVOKAT wird gemeinsam mit Microsoft SharePoint eingesetzt.

  • Es kommt bei Verwendung der Funktionen "Einstellungen korrigieren" oder "Security korrigieren" im SharePoint-Tool "Advokat8.DMS.Sharepoint.Manager.exe" zu einer Fehlermeldung.

Beispiele (Fehlermeldungen)

  • System.UnauthorizedAccessException: <nativehr>0x80070005</nativehr><nativestack></nativestack>

Ursache

Das SharePoint-Tool wird mit einem Windows Benutzerkonto ausgeführt, welches nicht über alle erforderlichen Berechtigungen seitens Microsoft SharePoint verfügt.
Dies kann auch zutreffen, wenn es sich beim Windows Benutzerkonto um einen SharePoint Farmadministrator handelt.

Lösung

  1. Stellen Sie sicher, dass der verwendete Domänenbenutzer tatsächlich der "SharePoint-Administrator" ist. Häufigste Ursache ist, dass der falsche Benutzer gewählt wurde.

    • Der SharePoint-Administrator muss über Vollzugriff verfügen, damit ist gemeint, dass dieser Benutzer als "Websitesammlungsadministrator" (SiteCollection-Administrator) definiert ist.

  2. Führen Sie die Migration erneut durch, schlägt diese wieder fehl, dann definieren Sie den "SharePoint-Administrator" zusätzlich als SharePoint Farmadministrator.
    Nachdem der "SharePoint-Administrator" nun Websitesammlungsadministrator und Farmadministrator ist versuchen Sie die Migration wieder. Nur wenn diese erneut fehlschlägt wechseln Sie zu Schritt 3.
     

  3. Beenden Sie das SharePoint-Tool in der vorhandenen RDP-Sitzung am SharePoint-Server.

    • Verbinden Sie sich per Remotedesktop auf den Microsoft SharePoint-Server, als Windows Benutzerkonto muss jener SharePoint-Administrator gewählt werden unter dem Microsoft SharePoint initial installiert wurde.

    • Stellen Sie sicher, dass unter diesem Windows Benutzerkonto das ADVOKAT Netzlaufwerk ebenfalls eingebunden ist.

  4. Öffnen Sie per Windows Explorer das ADVOKAT Backend unter "...\ADVOKAT\Admin\Support\Adv2SharePoint" und starten das Tool "Advokat8.DMS.SharePoint.Manager.exe" erneut.
    Wechseln Sie retour zum Kapitel wo der weitere Ablauf für die Funktion "Einstellungen korrigieren" oder "Security korrigieren" beschrieben ist.

Copyright © 2024 ADVOKAT Unternehmensberatung GREITER & GREITER GmbH - Impressum ->https://advokat.at/Impressum.aspx