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6.3.9.9 Authentifizierung schlägt fehl

6.3.9.9 Authentifizierung schlägt fehl

Ausgangssituation

  • Es ist die Synchronisation mit Microsoft Exchange im Einsatz, siehe Kapitel Synchronisation mit Microsoft Exchange.

  • Die Synchronisation hat bereits fehlerfrei funktioniert, nun erscheint eine ganz bestimmte Fehlermeldung.

Fehlermeldung

  • You are using TLS Version 1.0, 1.1 and/or 3DES cipher which are deprecated to improve the security posture of azure AD.
    Your TenandID is: <TenantID>. Please refer to https://go.microsoft.com/fwlink/?linkid=2161187 and conduct needed actions to remediate the issue.
    For further questions, please contact your administrator.

Ursache

  • Es ist seitens Microsoft nicht mehr möglich, dass die Verbindung bzw. Authentifizierung der Synchronisation per TLS 1.0 oder 1.1 erfolgt.

  • Es muss eine Verbindung ausschließlich per TLS 1.2 erfolgen.

Hinweis

Der Windows-Dienst "AdvoAll-Dienst" bzw. bei englischsprachigen Betriebssystem "AdvoAll-Service" darf nicht beendet bzw. neu gestartet werden.

Lösung

  1. Verbinden Sie sich mit dem AdvoAll-Benutzerkonto (im Regelfall lautet dieses "Domäne\svc_advokat") per Remotedesktop auf das betroffene Gerät.

    • Den Gerätenamen können Sie den Fehlermeldungen beim Programmstart oder den Dateinamen von AdvoAll im ADVOKAT Backend unter "...\ADVOKAT\Daten\Config\AdvoAll" entnehmen.

    • Beispiel: SERVER$svc_advokat$AdvoAllService.status

  2. Starten Sie ADVOKAT auf dem AdvoAll-Gerät, dadurch wird sichergestellt, dass der ADVOKAT Client aktuell ist. Tritt das Problem weiterhin auf, so fahren Sie mit Schritt 3 fort.

  3. Starten Sie die AdvoAll-Oberfläche per “C:\Program Files (x86)\Advokat\AdvoAll.exe”. Markieren Sie den Eintrag "ADVOKAT_Exchange_Synchronisation". Wählen Sie Menüpunkt “Bearbeiten” > “Ändern”.

    • Im Fenster “Programmkonfiguration bearbeiten” deaktivieren Sie folgende drei Einstellungen:

      • Mit AdvoAll starten

      • Automatisches Update

      • Überwachung

    • Beenden Sie die Anwendung "ADVOKAT_Exchange_Synchronisation" indem Sie diese markieren und Rechtsklick "Beenden" auswählen.

      • Verwenden Sie die Funktion "Beenden erzwingen" nur, wenn nach Nutzung von "Beenden" und einer Wartezeit von 5 Minuten nichts passiert ist.

  4. Navigieren Sie per Windows Explorer zum ADVOKAT Backend unter "...\ADVOKAT\Daten\Config\AdvoAll" und öffnen Sie die Datei "AdvoAll.cfg" mit einem passenden Texteditor.

  5. Suchen Sie nach der Zeile <ExchangeSyncConfig ....>. Ergänzen Sie diese Zeile um den Parameter SecurityProtocols="...".

    • Über das Attribut SecurityProtocols kann eine Liste der Protokolle übergeben werden, die zusätzlich unterstützt werden sollen. Die einzelnen Einträge sind mit ";" getrennt anzuführen.

    • Standardmäßig wird TLS 1.2 unterstützt. Es sind folgende Werte verfügbar: Ssl3, Tls, Tls11, Tls12, Tls13

      • In diesem Beispiel wird durch die Anpassung nicht nur TLS 1.2, sondern zusätzlich TLS 1.3 unterstützt.

    • Beispiel (vorher)

      <ExchangeSyncConfig LogType="2">
    • Beispiel (nachher)

      <ExchangeSyncConfig LogType="2" SecurityProtocols="Tls12;Tls13">
  6. Speichern Sie die Konfigurationsdatei "AdvoAll.cfg" und öffnen Sie erneut die AdvoAll-Oberfläche per “C:\Program Files (x86)\Advokat\AdvoAll.exe”.

    • Markieren Sie erneut den Eintrag "ADVOKAT_Exchange_Synchronisation". Wählen Sie Menüpunkt “Bearbeiten” > “Ändern”.

      • Im Fenster “Programmkonfiguration bearbeiten” aktivieren Sie folgende drei Einstellungen:

        • Mit AdvoAll starten

        • Automatisches Update

        • Überwachung

    • Warten Sie 5 Minuten und prüfen danach bei der AdvoAll-Anwendung “ADVOKAT_Exchange_Synchronisation” ob der Status “Aktiv” angezeigt wird.

      • Ist das nicht der Fall, dann markieren Sie die Anwendung und wählen Menüpunkt “Aktion” > “Starten”.

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