1.7.10.6 Archivium V3 - Zertifikat nicht erkannt

Ausgangssituation

  • Es wird Archivium V3 (Version 3) verwendet. Bei V2 wechseln Sie zum Kapitel Archivium V2.

  • Es kommt beim Programmstart (Initialisierung) von Archivium zu einem Timeout (Fehlermeldung), es erscheint ein Dialog, dass die Smartcard in das Lesegerät gesteckt werden soll.

Fehlermeldung

  • Smartcardgerät auswählen
    Der angeforderte Vorgang kann mit der Smartcard nicht ausgeführt werden, oder für den Vorgang ist eine andere Smartcard erforderlich.

Ursache

Archivium prüft beim Programmstart die Gültigkeit des Rechtsanwaltsausweises. Dazu werden auch alle Zertifikate jener Rechtsanwaltsausweise geprüft, die auf diesem Rechner verwendet werden.
Das Timeout (Fehlermeldung) tritt auf, wenn bei der Überprüfung von A-Trust keine Antwort oder zu spät eine Antwort retourniert wird.

Der Standard-Zertifikatsfilter wurde in ADVOKAT analog zur Archivium Software mit "ADVOKAT;a-sign" definiert. Somit wurden alle ADVOKAT-Archivium sowie A-Trust Zertifikate auf Gültigkeit geprüft.

Lösung

  1. ADVOKAT prüft standardmäßig nur ADVOKAT-Archivium Zertifikate auf ihre Berechtigung in Archivium.
    Wurde im Archivium ein entsprechender ADVOKAT-Archivium Mitarbeiter mit dem von ADVOKAT gelieferten Zertifikat für jeden R-Code angelegt, können alle Möglichkeiten der Archivium Anbindung ohne Einschränkung genutzt werden.
     

  2. Soll ein Software-Zertifikat von A-Trust (a-sign-light) für die Verbindung mit Archivium verwendet werden, muss die Konfigurationsdatei "Kanzlei.cfg" von ADVOKAT angepasst werden.

    • Öffnen Sie den Windows Explorer und navigieren Sie zum ADVOKAT Backend unter "...\ADVOKAT\Daten\Config".

    • Öffnen Sie die Konfigurationsdatei "Kanzlei.cfg" mit einem passenden Texteditor. Mehr Informationen dazu finden Sie im Kapitel Kanzlei.cfg.

  3. Suchen Sie nach dem Eintrag "<Archivium ...>". Fügen Sie wie im Beispiel ersichtlich den Zertifikatsfilter wie folgt ein: Zertifikatsfilter="ADVOKAT;a-trust"

    • Beispiel (vorher)

      <Archivium Service="https://rest.anwaltsarchiv-v3.at:443"/>
    • Beispiel (nachher)

      <Archivium Service="https://rest.anwaltsarchiv-v3.at:443" Zertifikatsfilter="ADVOKAT;a-trust"/>

       

  4. Speichern Sie die Datei und schließen Sie ADVOKAT und Microsoft Office Outlook und starten Sie beide Programme erneut.

  5. Sind mehrere Rechtsanwaltsausweis-Zertifikate (a-sign-premium) am Arbeitsplatz vorhanden, kann dies bei der Gültigkeitsprüfung auch zu einem Timeout führen.

    • Standardmäßig wird für den Timeout ein Wert von 10 Sekunden angewendet, der Wert kann bis zu 60 Sekunden erhöht werden.

    • Öffnen Sie erneut die Konfigurationsdatei "Kanzlei.cfg" wie unter Schritt 2 beschrieben.

    • Suchen Sie erneut nach dem Eintrag "<Archivium ...>". Fügen Sie wie im Beispiel ersichtlich den Parameter für den Timeout wie folgt ein: InitTimeout"20"

      • Beispiel (vorher)

        <Archivium Service="https://rest.anwaltsarchiv-v3.at:443"/>
      • Beispiel (nachher)

    • Anmerkung: Der Wert von 20 ist nur ein Beispiel, in diesem Beispiel wurde der Timeout 10 auf 20 Sekunden erhöht.

  6. Speichern Sie die Datei und schließen Sie ADVOKAT und Microsoft Office Outlook und starten Sie beide Programme erneut.

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