1.7.2.2 Versionsabweichung nach Update

Ausgangssituation

  • ADVOKAT Update wurde erfolgreich durchgeführt und das Programm startet erfolgreich, danach erscheint am Startbildschirm untenstehende Fehlermeldung.

Fehlermeldung

  • Achtung! Die Versionen der Datenbanken und die Programmversion stimmen nicht überein. Sie sollten das neue Advokat-Update einspielen, da es andernfalls zu Fehlern in Advokat kommen kann.
    DATENBANKSERVER/Advokat_ADVOERV ist <Version> soll <Version>
    DATENBANKSERVER/Advokat_DATEN ist <Version> soll <Version>
    DATENBANKSERVER/Advokat_MAIL ist <Version> soll <Version>
    DATENBANKSERVER/Advokat_TABELLEN ist <Version> soll <Version>

Ursache
In den meisten Fällen ist die IST-Version (erste Nummer) niedriger als die SOLL-Version (zweite Nummer). Ursache ist eine fehlgeschlagene Datenbank- und/oder Tabellenaktualisierung von ADVOKAT.

Lösung

  1. Stellen Sie sicher, dass ADVOKAT, Microsoft Office Outlook und Microsoft Office Word vollständig geschlossen sind, kontrollieren Sie dies per Task Manager.

  2. Navigieren Sie per Windows Explorer im ADVOKAT Backend zu “…\ADVOKAT\Daten” und öffnen Sie Konfigurationsdatei “Advokat.ini” mit einem Texteditor.

    • Suchen Sie in der Datei nach dem Konfigurationsschalter “TabellUpdate“ und prüfen Sie den angeführten Pfad.

      • Es muss sich dabei um den Pfad zur ADVOKAT Systemdatei "Tabellen.mdb" unter "...\ADVOKAT\Admin\Setup" handeln.

      • Es handelt sich um eine andere Datei als jene laut Konfigurationsschalter "TabellBank".

    • In diesem Beispiel würde der korrekte Pfad “S:\ADVOKAT\Admin\Setup\Tabellen.MDB“ lauten.

  3. Navigieren Sie zum ADVOKAT Backend "...\ADVOKAT\Daten\Config\AdvoAll" und löschen Sie sämtliche Dateien mit der Dateiendung ".lock".

  4. Halten Sie die Taste "F12" gedrückt und starten Sie "...\ADVOKAT\Advokat.exe". Es erscheint das Fenster "Aktualisierung von ADVOKAT Edition 6", aktivieren Sie diese Optionen und drücken Sie auf "Fortsetzen":

    • Tabellen aktualisieren

    • Datenbanken aktualisieren

  5. Nun startet die automatische Reparatur von ADVOKAT. Warten Sie bis der Fortschritt 100% erreicht hat.

    • Treten Fehlermeldungen auf, so können Sie versuchen, diese mit Klick auf "Wiederholen" zu übergehen.

    • ADVOKAT wird versuchen die fehlgeschlagene Aktion erneut durchzuführen.

  6. Falls die erneute Aktualisierung erfolgreich war, so erscheint der Startbildschirm von ADVOKAT. Es kommt zur sogenannten Tabellenaktualisierung.

    • Sollte eine Abfragefenster "Es wurden Unterschiede gefunden" erscheinen, so ist die Schaltfläche "Nein" oder einmalig "Keine" zu wählen.

    • In der Programmhilfe (F1) im Kapitel "Tabellen aktualisieren" ist dies beschrieben. Sollten Sie sich auch nach Lesen der Hilfe nicht sicher sein, so wählen Sie den Eintrag "Keine".

    • Anschließend wäre das automatisch erzeugte Protokoll "Tabellen Einspielen" mit allen Abweichungen dem Kunden zur Kontrolle zu übergeben.

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